Lumio intermittent error

Incident Report for SMART Product Status

Resolved

Lumio is now stable. This incident is resolved. Thank you for your patience.
Posted Apr 08, 2026 - 21:00 UTC

Monitoring

We believe the issue has been resolved, and Lumio should now be stable. We will continue to monitor the system to ensure it remains stable.
Posted Apr 07, 2026 - 21:23 UTC

Update

We are monitoring the status of the service as we continue working to solve the problems that we were seeing last week.
Posted Apr 06, 2026 - 09:37 UTC

Update

We still see some intermittent issues with the service, so we are continuing to investigate the ongoing issue and monitoring the fix deployed.
Posted Apr 01, 2026 - 23:09 UTC

Update

We are continuing to investigate this issue.
Posted Apr 01, 2026 - 16:50 UTC

Update

We are continuing to investigate this issue.
Posted Mar 30, 2026 - 22:41 UTC

Update

We still see some intermittent issues with the service, so we are continuing to investigate the ongoing issue and monitoring the fix deployed.
Posted Mar 27, 2026 - 14:58 UTC

Update

Lumio is stable now and we will continue to monitor
Posted Mar 25, 2026 - 22:41 UTC

Update

Lumio is stable now and we will continue to monitor
Posted Mar 25, 2026 - 22:38 UTC

Update

We are continuing to investigate this issue.
Posted Mar 25, 2026 - 21:05 UTC

Investigating

We are still experiencing occasional errors and performance slowdowns as a result of high service load. The team is currently investigating.
Posted Mar 25, 2026 - 17:29 UTC

Update

We continue monitoring the situation after the fix released yesterday, making sure that the service is working as expected.
Posted Mar 25, 2026 - 14:23 UTC

Monitoring

A fix has been deployed and we are continuing to monitor the results.
Posted Mar 24, 2026 - 23:07 UTC

Investigating

Lumio is currently experiencing an intermittent issue preventing some users from using Lumio. Affected users may see a delay in loading Lumio or an error message: “website is temporarily unavailable”. We believe we have identified the cause and are working to resolve it.
Posted Mar 24, 2026 - 20:06 UTC
This incident affected: Lumio (Access to premium features, AI Assist, Creating and editing lessons, Delivering lessons, Immersive Reader, Importing and exporting resources, Lesson Previews, Link sharing, LTI Integration, Purchasing Lumio subscription via credit card, Sign In, Students joining live lessons).