The Google services we depend on are operational again and we have verified that SMART services are operating correctly.
Posted Jun 12, 2025 - 22:42 UTC
Update
Google is reporting that they have repaired the issue across most regions and we can confirm that SMART services and Lumio are available for many of our customers, but not all. There is no ETA for complete recovery, and we will continue to monitor.
Posted Jun 12, 2025 - 20:31 UTC
Monitoring
We are continuing to monitor the global cloud outage at Google, and expect SMART Services to be restored in tandem with the resolution of this outage. We will continue to provide updates as we see the status change.
Posted Jun 12, 2025 - 19:25 UTC
Investigating
Our cloud hosting provider is currently experiencing an outage which is impacting Lumio access and logins to other SMART products, including Notebook and iQ. We are investigating and will provide updates as we receive them.
Posted Jun 12, 2025 - 18:42 UTC
This incident affected: Interactive Displays (iQ) (Sign In with SMART Account), Notebook (Sign In), Admin Portal (Sign In), and Lumio (Sign In).