Lumio Outage - Middle East

Incident Report for SMART Product

Resolved

The issue has been resolved. Thank you for your patience.
Posted Apr 02, 2026 - 13:04 UTC

Update

A fix has been deployed and we are continuing to monitor the results.
Posted Apr 01, 2026 - 23:12 UTC

Investigating

Lumio is currently unavailable due to AWS regional outage in Middle East area. We are currently investigating the issue.
Posted Apr 01, 2026 - 16:58 UTC
This incident affected: Lumio (Access to premium features, AI Assist, Creating and editing lessons, Delivering lessons, Immersive Reader, Importing and exporting resources, Lesson Previews, Link sharing, LTI Integration, Purchasing Lumio subscription via credit card, Sign In, Students joining live lessons).