The issue is resolved. Users should be able to use all Lumio features.
Posted Oct 16, 2025 - 18:34 UTC
Update
We are continuing to investigate this issue.
Posted Oct 16, 2025 - 18:33 UTC
Investigating
There’s a Lumio disruption.
We are currently investigating issue where Users can't login to Lumio. Lumio users may see a 'website is temporarily unavailable message'.
We understand how important Lumio is for you. We apologize for any inconvenience this may cause and appreciate your patience.
We are currently investigating, and updates will be provided as more information becomes available.
Posted Oct 16, 2025 - 18:00 UTC
This incident affected: Lumio (Access to premium features, AI Assist, Creating and editing lessons, Delivering lessons, Importing and exporting resources, Lesson Previews, Link sharing, LTI Integration, Purchasing Lumio subscription via credit card, Sign In, Students joining live lessons).