Slowness loading lessons in My Library

Incident Report for SMART Product

Resolved

This incident has been resolved.
Posted Sep 15, 2026 - 15:14 UTC

Monitoring

The API requests are working now as expected, we remain monitoring to ensure that the system continues behaving as normal
Posted Sep 15, 2026 - 14:46 UTC

Identified

The issue has been identified and the infrastructure is scaling to resolve the problem.
Posted Sep 15, 2026 - 14:33 UTC
This incident affected: Lumio (Creating and editing lessons, Delivering lessons, Lesson Previews, Link sharing).